November 19, 2017, 03:04:09 PM

Username
Password

Pages: [1] 2   Go Down
Print
Author Topic: Dark Omen in Full 3D Mode High Res XP and No Flicker!  (Read 43104 times)
0 Members and 1 Guest are viewing this topic.
olly
Global Spokesperson
*
Offline Offline

Posts: 1833



View Profile
« on: March 21, 2009, 12:17:41 AM »

***2 new fixes for Win 7 & 8 Full 3d Mode *****

http://forum.dark-omen.org/help-section/3d-mode-and-win8-dark-omen-t1164.0.html;msg12011#msg12011






Below describes the original investigation and testing ->



***BackUp Your Dark Omen Folder Before Attempting Any Modifications****

***Use the Intro crash Fix to Restore Dark Omen Graphics Options******

***Do Not Use Alt Tab, Unless You Press Esc to Pause the Game First******

GUIDE TO FIX - > http://forum.dark-omen.org/help-section/dark-omen-in-full-3d-mode-high-res-xp-and-no-flicker-t248.0.html;msg1394#msg1394


Today I have been Testing Dark Omen Running in Full 3D Mode on my XP Laptop.

My Guide Allows it to Work BUT it requires connecting to a CRT Monitor to

Achieve Refresh Rates of 100Hertz or more. This will Help Stop the Flickering.


1) Download the latest Nvidia Forceware Graphics Card drivers (haven't Tested on ATi and others yet)

2) Open NVidia Control Panel and go to Manage 3d Settings and Add EngRel.exe of Dark Omen.

See Above Posts for Detailed Pictures:-          

Set Options to:-


Anisotropic Filtering                           = Off
Antialiasing -Gamma Correction            = Use Global setting (Off)
Antialiasing - Setting                         = None
Antialiasing - Transparency                 = Off
Conformant texture clamp                   = Off
Extension limit                                   = On
Force mipmaps                                  = None
Multi-display/mixed GPu accer              = Single Display performance mode
Texture filtering -Anisotroipc mip          = Greyed out (Off)
Texture filtering -Anisotroipc  sample    = Greyed out (Off)
Texture filtering -Negative LOD bias      = Use Global Setting (Allow)
Texture filtering -Quality                     = High Quality
Texture filtering -Trilinear optimisation   = Greyed out (Off)
Triple buffering                                  = On
Vertical Sync                                     = Force On



3) Then Connect the latop to a CRT Monitor and Set the CRT as the Primary Display (Fn -F8)

4) Then Set the Adaptor Refresh Rate to 100Hertz or more, even use 640x Screen Res at 100hz.

5) Start Dark Omen and Set to 3D Mode and High Resolution and Start Campaign

6) Perfect! and no Flicker!


Smiley




(I will continue to Optimise this Guide and of course seek for a way to Allow Flat

Screen Monitors to Work, although it may require them to have a 8ms Response Time

that also Runs at 100hz and my Laptop Screen only does 60hz.


http://computing.kelkoo.co.uk/p-computer-monitors-114401/samsung-syncmaster-460p-46-15418285#specs


*Update April 2012 using latest Forceware drivers*
« Last Edit: May 24, 2013, 04:29:36 PM by olly » Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
olly
Global Spokesperson
*
Offline Offline

Posts: 1833



View Profile
« Reply #1 on: March 21, 2009, 03:25:24 AM »

Dark Omen Finally Running in Full 3D Mode High Res on Windows XP! and No Flicker! 

After much Experimenting (see above Post) I was still getting the same Old Flicker on XP 3D Mode.

Until I Set my "CRT Monitor" Refresh Rate to 100Hertz and it Worked!

Smiley








Now I have Certainly Tried this in the Past, To Out Flicker the Flicker!

By Increasing my Refresh Rate to 100hz  and it Never did anything!

So here are all My Settings that I also changed tonight!










There was alot Of Nvidia Graphics Property Chages!











(I must also state that I copied ShadowOfTheHornedRatCD\DIRECTX files and

ShadowOfTheHornedRatCD\DIRECTX\DRIVERS\DISPLAY\MSDDRAW   

Into C:\WINDOWS\system32 which replaced my original ddraw.dll) 


and Perhaps most Crucially altering the Registry to 252  that my Tests saw Less Flicker






Just as I was nearly collapsing with Epilepsy at 2:26am, after 6hrs of Flickering Dark Omen

I remembered I had tried ages ago to solve The Flicker using Screen Refresh Rate but to no avail.


So I thought I would to give Tonight's Tests one last try and increase My CRT's refresh Rate to 100hz.

and it Worked! Unfortunately alot of your Flat Screen Monitors may not be able to do this as they may

only go upto 75hz and are different Technologies so no Refresh Rate but Response Times instead.



So i will try and keep the noise Down as I celebrate!

I Can't Wait to Test it Online Multiplayer Dark Omen in Full 3D on WinXp!


 Cool




At this point in Time I belive it to be the Registry Tweak that Appeared to make it Flicker slighty less

which allowed my CRT at 100hertz Refresh Rate to Finally OverPower the Flicker by Refreshing Faster.

Although the Combination of Nvidia Settings were also causing different Optimal Graphical Effects.




Us Modders will of Course Test this fully and should be able to

Produce a Guide based on my Further Testing to determine the FIX!

To Hopefully Allow Everyone to Finally Play Online Dark Omen in Full 3D on XP /Vista on Flat Screen Monitors!


Smiley

« Last Edit: March 21, 2009, 08:33:14 PM by olly » Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
Flak
Super Moderator
*
Offline Offline

Posts: 1463


Jake Nielsen


View Profile WWW
« Reply #2 on: March 21, 2009, 01:39:54 PM »

hehe my goblin campaign is used  Grin

« Last Edit: March 21, 2009, 08:32:46 PM by olly » Logged

"There is only one way out of hell, thats through it" -- General Patton

"Just because a mage wears the Black Robes, does not make him evil." -- Raislin Magere

"Evil Turns upon it self" -- Paladine
olly
Global Spokesperson
*
Offline Offline

Posts: 1833



View Profile
« Reply #3 on: March 21, 2009, 07:47:05 PM »

Today I have been Testing Dark Omen Running in Full 3D Mode on my XP Laptop.

My Guide Allows it to Work BUT it requires connecting to a CRT Monitor to

Achieve Refresh Rates of 100Hertz or more. This will Help Stop the Flickering.


1) Download the latest Nvidia Forceware Graphics Card drivers (haven't Tested on ATi and others yet)

2) Open NVidia Control Panel and go to Manage 3d Settings and Add EngRel.exe of Dark Omen.

See Above Posts for Detailed Pictures:-          

Set Options to:-


Anisotropic Filtering                           = Off
Antialiasing -Gamma Correction            = Use Global setting (Off)
Antialiasing - Setting                         = None
Antialiasing - Transparency                 = Off
Conformant texture clamp                   = Off
Extension limit                                   = On
Force mipmaps                                  = None
Multi-display/mixed GPu accer              = Single Display performance mode
Texture filtering -Anisotroipc mip          = Greyed out (Off)
Texture filtering -Anisotroipc  sample    = Greyed out (Off)
Texture filtering -Negative LOD bias      = Use Global Setting (Allow)
Texture filtering -Quality                     = High Quality
Texture filtering -Trilinear optimisation   = Greyed out (Off)
Triple buffering                                  = On
Vertical Sync                                     = Force On



3) Then Connect the latop to a CRT Monitor and Set the CRT as the Primary Display (Fn -F8)

4) Then Set the Adaptor Refresh Rate to 100Hertz or more, even use 640x Screen Res at 100hz.

5) Start Dark Omen and Set to 3D Mode and High Resolution and Start Campaign

6) Perfect! and no Flicker!


Smiley




(I will continue to Optimise this Guide and of course seek for a way to Allow Flat

Screen Monitors to Work, although it may require them to have a 8ms Response Time

that also Runs at 100hz and my Laptop Screen only does 60hz.


http://computing.kelkoo.co.uk/p-computer-monitors-114401/samsung-syncmaster-460p-46-15418285#specs

*Update April 2012 using latest Forceware drivers as latest nvidia drivers caused black artefacts *







(Yes Flak, your Goblin Campaign has never Looked So Good!)

Wink
« Last Edit: April 09, 2012, 10:18:42 PM by olly » Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
alavet
Orc Shaman
*
Offline Offline

Posts: 1004



View Profile
« Reply #4 on: March 24, 2009, 09:18:03 AM »

so do you basically think that if i have flat monitor which has 8ms response at ability of handling 100Hz i may use DO in 3d without flickering?

should i test it?
Logged

Battle not with monsters, lest ye become a monster, and if you gaze into the abyss, the abyss gazes also into you.
olly
Global Spokesperson
*
Offline Offline

Posts: 1833



View Profile
« Reply #5 on: March 24, 2009, 10:47:21 PM »

If you have time Test, that would be Great!

Pleas tell me your Pc Specificitions:-

WinXP/Vista
Nvidia/ATi
TFT/CRT

etc ..

Smiley

Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
alavet
Orc Shaman
*
Offline Offline

Posts: 1004



View Profile
« Reply #6 on: March 25, 2009, 07:38:27 AM »

sorry bro i just have rather good monitor (24') and thought that it may handle 100hz
but actually as i got yesterday it may handle only 85 hz so i guess there is no point for test?

for futher questions you may talk me in irc (exe) or hamachi
Logged

Battle not with monsters, lest ye become a monster, and if you gaze into the abyss, the abyss gazes also into you.
gatovaca17
Orc Boy
*
Offline Offline

Posts: 31


Jaque Mate


View Profile
« Reply #7 on: April 02, 2009, 11:15:09 AM »

I'll test it today on my Asus 24"@75hz 2ms refresh & my Sony Bravia TV 26"@60hz 5ms refresh
Graphic Card: nVidia GTX260Top
WinXP32Pro
But i doubt it works on LCDs.

Thx a lot for ur researching Smiley
CRT ftw!
Logged
alavet
Orc Shaman
*
Offline Offline

Posts: 1004



View Profile
« Reply #8 on: May 08, 2009, 08:42:39 PM »

hey very very mnice q-ty picks, is it possible to create .reg file to make all these nvidia settings? would be very nice cause im lazy!
Logged

Battle not with monsters, lest ye become a monster, and if you gaze into the abyss, the abyss gazes also into you.
olly
Global Spokesperson
*
Offline Offline

Posts: 1833



View Profile
« Reply #9 on: May 10, 2009, 02:34:17 PM »

After Discussing the Merits of 3D mode with Ghabry I mentioned some old 3rd party

Force Refresh Rate software that I once tried, when forcing Operation Flashpoint 1

to play on a Radeon 9800pro 256mb card. Now I certainly don't like to Force Monitors

to go Higher than their maximum settings, so we are considering Sync'ing the Game Frame

Rates to hopefully eliminate the Flicker/Blinking in 3d mode when using a TFT Flat 60hz screen

and not CRT or very latest new TFTs with 8ms repsonse Times, now with 100hz as well.


http://www.pagehosting.co.uk/rf/


Refresh Force actually helps my 3d mode work better on this Nvidia and CRT monitor as now i can play

at 1024 x 768, 32bit @ 75hz Refresh Rate (normal mode) and doesn't Flicker, where as 640 @100hz was best


I have tried it with and without and it does have a positive effect on stopping flicker,despite the game always

running in 640 resolution as default,so at very least saves me swapping Screen Resolutions and Refresh Rates.




The problem with Laptop TFT is that I can almost reduce the flicker in 3d mode but the game looks dull, until

I disable Vsync in Nvidia Control Panel but then it creates Bands of Black lines that Flicker worse, however it is

worth pursuing and here are some other usefull tools that I am currently testing. Ideally we want to fix the Sync

Rate, rather than turn it Off or On- possibly.


Riva Turner -
Power Strip-
Force Refresh-
Nvidia Control Panel-

Smiley
« Last Edit: May 10, 2009, 02:40:58 PM by olly » Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
sipax
Campaign Creator
*
Offline Offline

Posts: 147



View Profile
« Reply #10 on: October 30, 2009, 10:18:31 AM »

There is one trouble: i cant set 100hz, 85 is max. (Geforce 5200)
Logged

- -
Urblab Rotgut: "My name's Urblab Rotgut."
Morgan Bernhardt: "That's your problem"
- -
MadMaxx
Troll
*
Offline Offline

Posts: 1



View Profile
« Reply #11 on: September 16, 2011, 04:20:02 PM »

After many experiments, I believe that the cause of flickering is bypassing of blitting functions by the graphics card drivers.

1. On a Windows 98 SE system, I had the following results:
- Voodoo2/Voodoo2 SLI with pre-DX7 drivers : no flickering
- Voodoo3 with pre-DX7 drivers : no flickering
- Voodoo2/Voodoo2 SLI with DX7 drivers : flickering/crashing
- Voodoo3 with DX7 drivers : flickering/crashing
- Voodoo5500 with DX7/DX7+ drivers : flickering/crashing
- TNT2/GeForce2MX/GeForce4MX/GeForce6800GT with latest drivers : flickering/crashing
- GeForce6800GT with latest drivers and forced blitting : no flickering !!!
  The game still runs fine with anisotropic filtering enabled, but has problems with the antialiasing function.

To force blitting on a nVidia card, use RivaTuner (Driver Settings/DirectX Settings/Blitting -> check "Always wait after blit"), this seems to solve the problem.

On a Windows XP Pro system with GeForce8800GTS 512 using the latest drivers, forcing blitting resolves the flickering issue, but the image is distorted (deformed/off-place "polygons"), as seen also with other older games (e.g. Incoming).
Possibly using and older driver may help running fine the game in Windows XP.
Logged
olly
Global Spokesperson
*
Offline Offline

Posts: 1833



View Profile
« Reply #12 on: September 17, 2011, 12:30:32 AM »

Good research & investigation, thnx

Smiley
Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
AnmanIndustries
Giant Spider
*
Offline Offline

Posts: 11


View Profile
« Reply #13 on: September 17, 2011, 03:48:04 PM »

I also gave this a shot earlier today. After reading all of this thread and playing with a number of tools, I could not get it to stop flickering. However, the computer does have 2 GTX 580 DCU 2's in SLI. I was physically unable to bring it down to 10 year ago technology. I did get close when modifying the refresh rate and adjusting various settings. Zoomed all the way in and it was good, zoomed out and a zebra crossing slowly made its way across the screen.

After all of that, I am now unable to turn on 3d at all. Stuffed if I know what I did after all of that.

Also discovered that leaving the game in compatibility mode made my sound break into white noise and stuff up good like.
Logged
olly
Global Spokesperson
*
Offline Offline

Posts: 1833



View Profile
« Reply #14 on: September 18, 2011, 04:01:11 PM »

yep, the only way is to have an Nvidia card and a monitor/TV capable of 100mhz (as well as a good response time if a TFT Flat screen) but luckily they are becoming more affordable now. However, as Ghabry points out, it would make your FRAPS video recordings 100 FPS as well (huge filesize), if you ever want to record your battles in full 3d mode.

My Guide Allows it to Work BUT it requires connecting to a CRT Monitor or new Flat screens to

Achieve Refresh Rates of 100Hertz or more. This will Help Stop the Flickering.


1) Download the latest Nvidia Graphics Card drivers (haven't Tested on ATi and others yet)

2) Open NVidia Control Panel and go to Manage 3d Settings and Add EngRel.exe of Dark Omen.

See Above Posts for Detailed Pictures:-          

Set Options to:-


Anisotropic Filtering                           = Off
Antialiasing -Gamma Correction            = Use Global setting (Off)
Antialiasing - Setting                         = None
Antialiasing - Transparency                 = Off
Conformant texture clamp                   = Off
Extension limit                                   = On
Force mipmaps                                  = None
Multi-display/mixed GPu accer              = Single Display performance mode
Texture filtering -Anisotroipc mip          = Greyed out (Off)
Texture filtering -Anisotroipc  sample    = Greyed out (Off)
Texture filtering -Negative LOD bias      = Use Global Setting (Allow)
Texture filtering -Quality                     = High Quality
Texture filtering -Trilinear optimisation   = Greyed out (Off)
Triple buffering                                  = On
Vertical Sync                                     = Force On



3) Then Connect the latop to a CRT Monitor and Set the CRT as the Primary Display (Fn -F8)

4) Then Set the Adaptor Refresh Rate to 100Hertz or more, even use 640x Screen Res at 100hz.

5) Start Dark Omen and Set to 3D Mode and High Resolution and Start Campaign

6) Perfect! and no Flicker!


Smiley




(I will continue to Optimise this Guide and of course seek for a way to Allow Flat

Screen Monitors to Work, although it may require them to have a 8ms Response Time

that also Runs at 100hz and my Laptop Screen only does 60hz.


http://computing.kelkoo.co.uk/p-computer-monitors-114401/samsung-syncmaster-460p-46-15418285#specs
« Last Edit: September 18, 2011, 11:27:06 PM by olly » Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
Pages: [1] 2   Go Up
Print
Jump to: