June 29, 2017, 03:20:55 PM

Username
Password

Pages: 1 [2]   Go Down
Print
Author Topic: Dark Omen in Full 3D Mode High Res XP and No Flicker!  (Read 41409 times)
0 Members and 1 Guest are viewing this topic.
Thoreg
Troll
*
Offline Offline

Posts: 3


View Profile
« Reply #15 on: November 11, 2012, 09:24:56 AM »

Hi,

At first, I'm new to the forum so hello everybody! I've been a Dark Omen fan for ages and it's good to see that I'm not alone with this.

Since I reinstalled the game after some years I've been wondering why does the screen flicker if I turn on 3D and finally I found the answer here. Well, another good reason to get a good old CRT next to the fact that light guns also work only with them (The House of the Dead powa).

Well, I couldn't find anywhere a comparison of the graphics of Dark Omen with 3D turned on and off, so I decided to make one. Since it flickers with 3D on I had to pause the game with Esc but luckily the menu doesn't hide too much of the screen.

Screenshot 1 3D OFF:

Screenshot 1 3D ON:

Screenshot 2 3D OFF:

Screenshot 2 3D ON:


Well there IS difference between the two modes, especially the faces are smoother with 3D on (the black squares are also just rendering flaws). But in the end the game's resolution is 640x480 and if I resize the screen to Full HD the difference won't matter that much. Smiley I hope somone will find this interesting!

Cheers,
Thoreg
Logged
Ghabry
Developer
*
Offline Offline

Posts: 1007



View Profile
« Reply #16 on: November 11, 2012, 02:10:05 PM »

We have no idea why it flickers.
But the "solution" is really to run Win98 or run a monitor at 100 or more Hz.
I guess that it still flickers, but our eyes are too slow to see this.
Logged

olly
Global Spokesperson
*
Offline Offline

Posts: 1811



View Profile
« Reply #17 on: November 11, 2012, 08:11:49 PM »

Nice comparison pictures thanks, here's some more info ->

Full 3d mode has transparent Water


and also allows Sprite filtering (Options Menu) that improves their looks


In 3d mode there are a Higher amount of Dead bodies that remain alot longer on the Battlefield and also more Particle Effects (polygons)





At least in the near future, when all TFT Flat Screen Monitor/Tvs (100Hz capable) are cheaper, then we can all play each other in 3d mode again! (Also Requires Nvidia Graphics Options etc..)

http://accessories.euro.dell.com/sna/productdetail.aspx?c=uk&l=en&s=dhs&cs=ukdhs1&sku=376160&~ck=bncat&~bk=gr:CategoryRec_catpab2,g:MostBought,rk:

Smiley
« Last Edit: November 12, 2012, 11:40:12 AM by olly » Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
Thoreg
Troll
*
Offline Offline

Posts: 3


View Profile
« Reply #18 on: November 12, 2012, 04:59:53 AM »

We have no idea why it flickers.
But the "solution" is really to run Win98 or run a monitor at 100 or more Hz.
I guess that it still flickers, but our eyes are too slow to see this.

Mmm so you say under Win98 we wouldn't need a 100 Hz monitor? What about Virtual PC? Is it possible to create a virtual Win98?

Olly, thanks for the screens they're great! Smiley
Logged
Ghabry
Developer
*
Offline Offline

Posts: 1007



View Profile
« Reply #19 on: November 12, 2012, 05:26:44 PM »

No VirtualPC has no 3D support (and all other Virtual Machine Programs dont support 3D under 98)
Logged

Sark
Troll
*
Offline Offline

Posts: 4



View Profile
« Reply #20 on: November 27, 2013, 07:28:14 AM »

Oh man, I've been trying to get 3D mode to work for hours. I've tried everything I could find here to no avail, the 3D setting is still greyed out for me. Does anyone have any idea what could be wrong?
Logged
olly
Global Spokesperson
*
Offline Offline

Posts: 1811



View Profile
« Reply #21 on: November 27, 2013, 02:07:51 PM »

If your are using Windows XP there is no fix for full 3D, unless you use Win 7 or Win 8

http://forum.dark-omen.org/help-section/3d-mode-and-win8-dark-omen-t1164.0.html

Then you can use a Hex Edited EngRel.exe to make it work, if you do have Win 7 or Win 8 then I can send you my EngRel.exe and registry settings to allow 3d mode not be greyed out.

Smiley
Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
Ghabry
Developer
*
Offline Offline

Posts: 1007



View Profile
« Reply #22 on: November 27, 2013, 04:48:19 PM »

Do you have the Vista/Win7 Fix installed? That compatibility fix disables the 3d mode, sorry. Sad

Logged

Pages: 1 [2]   Go Up
Print
Jump to: