May 28, 2020, 12:28:58 PM

Username
Password

Pages: [1]   Go Down
Print
Author Topic: Keyboard Issue  (Read 9620 times)
0 Members and 1 Guest are viewing this topic.
jaybirdr007
Troll
*
Offline Offline

Posts: 2


View Profile
« on: May 12, 2009, 04:17:31 PM »

I was a huge fan of SotHR, and just found Dark Omen. The one problem I'm having with the game is that my keyboard isn't being recognized, except to alt tab. I can't type in the saved games, and the worst part, is that I can't zoom in or out during battles. Is there any way to fix this?
Logged
olly
Global Spokesperson
*
Offline Offline

Posts: 1994



View Profile
« Reply #1 on: May 12, 2009, 04:39:45 PM »

Hi and Welcome!

Smiley


My initial thoughts would be to purchase a USB to PS2 adaptor,

if your Keyboard is USB and if your pc has PS2, or PS2 to USB adaptor,

if your keyboard is old style PS2 port pins.



However, if all your other games work fine, then perhaps reinstall Dark Omen

or update the Keyboard's Driver but the only time I have experienced this problem

is after Alt Tabbing multiple times and it seems to loose its keyboard functions.


I will investigate further unless some one else can offer a better soultion.

(Do u use the Intro Crash fix and other Game Fixes? and please state if u are on Vista or XP)

http://forum.dark-omen.org/help-section/ultimate-dark-omen-game-fixes-t111.0.html

Smiley
Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
Ghabry
Developer
*
Offline Offline

Posts: 1020



View Profile
« Reply #2 on: May 12, 2009, 04:49:26 PM »

I also have this problem sometimes in Dark Omen.
The solution is restarting Dark Omen (doesn't always fix it) or rebooting.
(I'm using a USB-Keyboard on one PC where I sometimes have this problem, on my laptop I never had this problem for now (dunno how the keyboard is internal connected))
Logged

alavet
Orc Shaman
*
Offline Offline

Posts: 1004



View Profile
« Reply #3 on: May 12, 2009, 06:49:50 PM »

for me solution is to switch keyboard language from russian to english before start
Logged

Battle not with monsters, lest ye become a monster, and if you gaze into the abyss, the abyss gazes also into you.
jaybirdr007
Troll
*
Offline Offline

Posts: 2


View Profile
« Reply #4 on: May 12, 2009, 09:14:03 PM »

I managed to solve it- I tried restarting in a bunch of times. I ended up holding the right mouse button, clicking the center wheel (Which brings up an interface that lists all the programs I have running, kind of like a mac) and then clicked back on the game. Somehow that magically did it.Smiley Thanks for the tips, I'm wicked excited to play:)
Logged
Jagdfalke
Troll
*
Offline Offline

Posts: 4


View Profile
« Reply #5 on: November 04, 2015, 10:10:17 AM »

Hi guys

I'm really sorry to thread necro but i JUST got dark omen working and am super hyped to play after all these years, but my keyboard won't work! The game just won't recognise any inputs, but the keyboard itself still works while I am in game as I can alt tab and alt f4 to get out of it. But I can't zoom or scroll using the keyboard! Does anyone have a suggested fix to this? Tried restarting and changing my keyboard language to US, but neither worked.

My keyboard is a logitech G15 and is a USB keyboard.

Any help would be much appreciated!

Thanks!
Logged
Ghabry
Developer
*
Offline Offline

Posts: 1020



View Profile
« Reply #6 on: November 04, 2015, 10:19:13 AM »

Did you try restarting your PC?
Logged

Jagdfalke
Troll
*
Offline Offline

Posts: 4


View Profile
« Reply #7 on: November 04, 2015, 10:22:58 AM »

Yep I have restarted the PC, restarted game several times and tried a fresh reinstall
Logged
Ghabry
Developer
*
Offline Offline

Posts: 1020



View Profile
« Reply #8 on: November 04, 2015, 10:32:40 AM »

Try the Mod Selector (install by extracting it in PRG_ENG (where the original EngRel.exe is) and run the new EngRel.exe.
And set compatibility settings (right click -> settings) to 640x480 and 16bit.
Logged

Jagdfalke
Troll
*
Offline Offline

Posts: 4


View Profile
« Reply #9 on: November 04, 2015, 10:36:38 AM »

Thanks for the replies Ghabry - appreciate it.

I will give that a go and let you know how it works
Logged
Jagdfalke
Troll
*
Offline Offline

Posts: 4


View Profile
« Reply #10 on: November 04, 2015, 10:44:01 AM »

That worked! You're a legend Ghabry!

One more thing, I broke DO recently by enabling coloured cursors and it took me ages to fix it, are there any other options I should avoid adjusting? Can I adjust sprite filtering and particle effects without breaking the game?
Logged
Ghabry
Developer
*
Offline Offline

Posts: 1020



View Profile
« Reply #11 on: November 04, 2015, 10:47:26 AM »

The only critical setting is the color cursor, the others are safe to use
« Last Edit: November 04, 2015, 11:07:32 AM by olly » Logged

fedev80
Troll
*
Offline Offline

Posts: 1


View Profile
« Reply #12 on: July 04, 2016, 08:24:48 PM »

Hello guys,

I'm haing the same issue, the keyboard doesn't work except alt+tab and alt+F4. I've tried everything... I have a notebook running under Windows 10. Did anyone find another solution?

Logged
olly
Global Spokesperson
*
Offline Offline

Posts: 1994



View Profile
« Reply #13 on: July 04, 2016, 08:58:49 PM »

Hi, please download the latest Mod pack that fixes Dark Omen to run on Win 10

http://forum.dark-omen.org/help-section/ultimate-dark-omen-xpvistawin7win81win10-game-fixes-t111.0.html

Smiley
Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
Pages: [1]   Go Up
Print
Jump to: