December 04, 2022, 06:40:08 AM

Username
Password

  Show Posts
Pages: [1]
1  Warhammer Dark Omen / Help Section / Re: Graphical issues on Geforce 2 MX - Help? on: January 23, 2022, 05:34:19 PM
I've now solved this issue.

I was using the 8.xx drivers from Nvidia but after many, many attempts with drivers which resulted in no 3D, no video, freezing and even BSOD I finally found that the nVidia Detonator/FW Driver v23.11 driver is the one which works perfectly with Dark Omen full 3D mode normal resolution at 60Hz.

Now, onward to the dread king!  Grin
2  Warhammer Dark Omen / Help Section / Re: Graphical issues on Geforce 2 MX - Help? on: January 23, 2022, 01:03:02 AM
I tried the black and white mouse, sadly same effect and i get this:



I also tried Rivatuner and it's doing the same thing.  Cry
3  Warhammer Dark Omen / Help Section / Re: Graphical issues on Geforce 2 MX - Help? on: January 22, 2022, 09:38:34 PM
Hi thanks for the welcome and thanks for making this site. Great to see other fans out there for this great game.

I've got a 19 inch LCD which is either 60hz or 75hz. I'd love a CRT ... supppperrrr smooth but i don't have the room and they aren't common here anymore.

How can i fix these in game issues? Undecided any ideas?

4  Warhammer Dark Omen / Help Section / Re: Graphical issues on Geforce 2 MX - Help? on: January 22, 2022, 08:17:34 PM
Forgot to mention I have tried to no flicker patched version (the one which installs with portugese or spanish text) and also the original CD that i own, both versions do this so I'm a bit stuck as to what do to next. I'm running Windows 98 SE.
5  Warhammer Dark Omen / Help Section / Re: Long-time Warhammer fan trying to play Dark Omen for the first time on: January 22, 2022, 07:43:03 PM
Not that i can help much with your situation but i will just say.. you will LOVE dark omen! You are in for a treat!

Enjoy it!  Grin
6  Warhammer Dark Omen / Help Section / Graphical issues on Geforce 2 MX - Help? on: January 22, 2022, 07:41:24 PM
Hi all

I've been fighting this battle for some time now. My favourite PC game is Dark Omen and I'm aware it is very funny about which graphics card it will play nicely with in terms of actually displaying graphics correctly and also enabling 3D hardware acceleration.

So, I've tried a ATI Rage Mobility 8MB on a Compaq M700 Pentium III laptop which runs without any graphical issues however, it runs so slow! The FPS is terrible but i can enable 3D mode which is helps but still, no good with the FPS.

So I then got myself a Toshiba Tecra M2 laptop with a Geforce FX Go 5200 in it as I'd heard on this forum that the FX series do work well with Dark Omen (despite being so much newer which i find odd.) Anyway, this does work perfectly without any graphical issues and the frame rate is smooth as butter (capped at 60fps i believe?)

Now, I'm building a Pentium 3 rig with a nice big 19 inch monitor for retro games and especially Dark Omen and I'm trying to keep it period correct. It's a P3 866Mhz with a Sound Blaster 16 ISA card and a Geforce 2 MX AGP 4x card. I thought this would run without any problems being somwhat around dark omens era give or take a couple of years but it's running very strangely.









I thought being somewhat period correct this would work fine but it's having a lot of trouble it seems which is a shame as the FPS for whatever reason is the smoothest i've ever experienced on Dark Omen. I don't know if it's just me but playing games with cards that were from that actual era always seem to have this REALLY smooth feel about them.

Anyway, any ideas how i can fix this? The main menu also flickers at the lower part of the screen but nothing this bad. I'm using Nvidia 8.xx drivers it's a Geforce MX 2 which i really don't want to swap out if i can as it's a great card for this system i think and it runs other games like Quake, Quake II, Unreal Tournament etc so well.

Thanks in advance.
Pages: [1]