December 04, 2022, 06:37:27 AM

Username
Password

Pages: [1]   Go Down
Print
Author Topic: Graphical issues on Geforce 2 MX - Help?  (Read 999 times)
0 Members and 1 Guest are viewing this topic.
pentium3retro
Giant Scorpion
*
Offline Offline

Posts: 6


View Profile
« on: January 22, 2022, 07:41:24 PM »

Hi all

I've been fighting this battle for some time now. My favourite PC game is Dark Omen and I'm aware it is very funny about which graphics card it will play nicely with in terms of actually displaying graphics correctly and also enabling 3D hardware acceleration.

So, I've tried a ATI Rage Mobility 8MB on a Compaq M700 Pentium III laptop which runs without any graphical issues however, it runs so slow! The FPS is terrible but i can enable 3D mode which is helps but still, no good with the FPS.

So I then got myself a Toshiba Tecra M2 laptop with a Geforce FX Go 5200 in it as I'd heard on this forum that the FX series do work well with Dark Omen (despite being so much newer which i find odd.) Anyway, this does work perfectly without any graphical issues and the frame rate is smooth as butter (capped at 60fps i believe?)

Now, I'm building a Pentium 3 rig with a nice big 19 inch monitor for retro games and especially Dark Omen and I'm trying to keep it period correct. It's a P3 866Mhz with a Sound Blaster 16 ISA card and a Geforce 2 MX AGP 4x card. I thought this would run without any problems being somwhat around dark omens era give or take a couple of years but it's running very strangely.









I thought being somewhat period correct this would work fine but it's having a lot of trouble it seems which is a shame as the FPS for whatever reason is the smoothest i've ever experienced on Dark Omen. I don't know if it's just me but playing games with cards that were from that actual era always seem to have this REALLY smooth feel about them.

Anyway, any ideas how i can fix this? The main menu also flickers at the lower part of the screen but nothing this bad. I'm using Nvidia 8.xx drivers it's a Geforce MX 2 which i really don't want to swap out if i can as it's a great card for this system i think and it runs other games like Quake, Quake II, Unreal Tournament etc so well.

Thanks in advance.
« Last Edit: January 22, 2022, 08:16:03 PM by pentium3retro » Logged
pentium3retro
Giant Scorpion
*
Offline Offline

Posts: 6


View Profile
« Reply #1 on: January 22, 2022, 08:17:34 PM »

Forgot to mention I have tried to no flicker patched version (the one which installs with portugese or spanish text) and also the original CD that i own, both versions do this so I'm a bit stuck as to what do to next. I'm running Windows 98 SE.
Logged
olly
Global Spokesperson
*
Offline Offline

Posts: 2161



View Profile
« Reply #2 on: January 22, 2022, 08:39:32 PM »

Hi and welcome, my win 98 pc with Geforce 2 mx plays original Dark Omen best when using a 19" CRT monitor capable of 100mhz refresh rate.

The ultimate way to play Dark Omen is on Win10 using dgvoodoo2 at high resolution but I do appreciate enjoyment of retro old PCs as kept all mine.

Smiley
Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
pentium3retro
Giant Scorpion
*
Offline Offline

Posts: 6


View Profile
« Reply #3 on: January 22, 2022, 09:38:34 PM »

Hi thanks for the welcome and thanks for making this site. Great to see other fans out there for this great game.

I've got a 19 inch LCD which is either 60hz or 75hz. I'd love a CRT ... supppperrrr smooth but i don't have the room and they aren't common here anymore.

How can i fix these in game issues? Undecided any ideas?

« Last Edit: January 22, 2022, 11:56:53 PM by pentium3retro » Logged
olly
Global Spokesperson
*
Offline Offline

Posts: 2161



View Profile
« Reply #4 on: January 23, 2022, 12:04:23 AM »

Have u tried Black and White Mouse Option instead of Colour?

Also try these Nvidia settings as looks like MadMax fixed the flickering on win98 and Geforce 2 MX by "forcing blitting on a nVidia card, use RivaTuner (Driver Settings/DirectX Settings/Blitting -> check "Always wait after blit"), this seems to solve the problem.

http://forum.dark-omen.org/help-section/dark-omen-in-full-3d-mode-high-res-xp-and-no-flicker-t248.0.html;msg10613#msg10613
« Last Edit: January 23, 2022, 12:19:28 AM by olly » Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
pentium3retro
Giant Scorpion
*
Offline Offline

Posts: 6


View Profile
« Reply #5 on: January 23, 2022, 01:03:02 AM »

I tried the black and white mouse, sadly same effect and i get this:



I also tried Rivatuner and it's doing the same thing.  Cry
Logged
pentium3retro
Giant Scorpion
*
Offline Offline

Posts: 6


View Profile
« Reply #6 on: January 23, 2022, 05:34:19 PM »

I've now solved this issue.

I was using the 8.xx drivers from Nvidia but after many, many attempts with drivers which resulted in no 3D, no video, freezing and even BSOD I finally found that the nVidia Detonator/FW Driver v23.11 driver is the one which works perfectly with Dark Omen full 3D mode normal resolution at 60Hz.

Now, onward to the dread king!  Grin
Logged
olly
Global Spokesperson
*
Offline Offline

Posts: 2161



View Profile
« Reply #7 on: January 23, 2022, 07:06:22 PM »

Excellent

Smiley
Logged

and back in Nuln, the ageing Graf Berhardt smiled his secret smile of pride whenever he heard the latest tales of his eldest son's ever growing chain of glorious victories -(sothr manual)
Pages: [1]   Go Up
Print
Jump to: